Can't install mailpile


#1

Hello there,
I am trying to install mailpile in accordance with the instructions, but I’m getting an error
Unable to locate package mailpile
:frowning:
I’ve added all repositories correctly…
sources.list:

 deb http://ftp.pl.debian.org/debian/ stretch main
    deb-src http://ftp.pl.debian.org/debian/ stretch main
   deb http://security.debian.org/debian-security stretch/updates main
    deb-src http://security.debian.org/debian-security stretch/updates main

    # stretch-updates, previously known as 'volatile'
    deb http://ftp.pl.debian.org/debian/ stretch-updates main

    deb https://packages.mailpile.is/deb release main
    deb-src http://ftp.pl.debian.org/debian/ stretch-updates main

please help…


#2

Hi!

That is not in accordance with our instructions on https://www.mailpile.is/download/linux.html - if you had followed those you would have ended up with a file in /etc/apt/sources.list.d

What you are doing should also work if you get everything else right - but I’m still going to recommend you actually follow our instructions as they are written. That is the procedure known to work, trying to figure out what you did wrong is a waste of everyone’s time when a known-to-work procedure is already documented.

Of course, if you had a good reason for doing things differently, or if our instructions are flawed, then we’d like to know and fix them docs! So please do let us know if that is the case. :slight_smile:


#3

sudo apt install mailpile Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mailpile : Depends: spambayes but it is not installable
Depends: python-appdirs but it is not installable
Depends: python-dns but it is not installable
Depends: python-pgpdump but it is not installable
Depends: python-icalendar but it is not installable
Recommends: tor but it is not going to be installed
Recommends: pagekite but it is not going to be installed
Recommends: python-stem but it is not installable
Recommends: wamerican-small but it is not going to be installed
Recommends: gnupg-curl but it is not installable
Unable to correct problems, you have held broken packages.

Using your apt repository with the current version (20.04 LTS) of Kubuntu