Asks for password re-entry often!


#1

This is an issue I have been facing frequently. I am being asked to re-enter IMAP account passwords although I choose save and remember. Wonder why this happens? Is this a bug?


#2

Sounds like an issue that I have encountered. It happens on just one of the two IMAP servers that I use. When Mailpile tries to login to the IMAP server, the server sometimes responds “[UNAVAILABLE] Server error”. Mailpile treats this the same as if a bad password had been entered. It won’t attempt another login until the correct password has been entered (confusing since the password was correct in the first place).

The IMAP server in question is using simple password authentication. Not sure if this issue could also arise with OAuth authentication. What type of authentication is your IMAP server using?

I have a patch that distinguishes between this type of error and actual bad passwords. I’ve been using it for some time but it needs to be cleaned up (to remove debug output) before I submit a pull request. Will try to do that in the not too distant future!


#3

I see. Thanks for the explanation. Curious, if this could happen due to connecting to servers via tor. Perhaps they don’t play nice.

I use a simple password authentication not OAuth. Will wait for the patch to roll out. Thanks for your help.


#4

Interesting. Thanks for reporting this, and thanks for the analysis @JackDca. Do we have an issue in GitHub for this? I think this qualifies as a bug.


#5

I don’t know if there is an open issue for this in GitHub. I disabled connecting via tor and everything works fine. Is it possible that some email services don’t work well with this option enabled or am I missing something?


#6

Oh yes, many providers block Tor because they think it’s a source of spam and abuse. Which of course, it is. But the rest of us deserve privacy too, so I think their policies are misguided.

Tor also slows things down, so the odds things will time-out go up a bit.

I believe there is an issue for enhancing our Tor support so we can opt out of using it for individual servers (technically that’s already possible, but the UI leaves much to be desired) while still using Tor for everything else.


#7

Hi Bjarni. I’ve been thinking that it was part of #1888 (the first item on the checklist). But, I see you’ve marked that item as done. Maybe it deserves a new issue.
I’ve been distracted by some non-Mailpile issues lately. You’ve given me more motivation to get my patch to a PR stage.
One problem is that testing is difficult - the ISP that gives me the weird errors does so very infrequently so I can’t do a test whenever I want to do so.


#8

Have you tried tweaking the mail source code, to generate fake errors that look similar enough to the real ones? That might help.


#9

I’ve done that - but for the final test I log debug data until the real error happens which can take weeks. Also I have not grokked how the bad password error causes the password popup to appear - if you can aim me the right way would appreciate it.